Mac Pro 4.1 Upgrade zu 5.1 – Firmwareupdate für Up- und Downgrade

  • Qualität
  • Handhabung
  • Preis/Leistung
  • Durchschnittlich
( 9 rated it )
  • Einfach und brignt viele Vorteile
  • Keine
  • Aus einem MacPro 4.1 mach MacPro 5.1. Speziell für Leute, die einen 6-Kern Westmere verbauen wollen.

Einigen sollte aufgefallen sein, dass die Mac Pros in den letzten Jahren auf gleichem Sockel basierten und die Änderungen minimal waren. Da musste man schon im Detail schauen, um zu sehen, was der Untershcied war. Das betraf besonders das kleine „Update“ vom MacPro 4.1 zum 5.1. Hier kommen neue XEON CPUs und schnellerer RAM zum Einsatz, der vom 1066 auf 1333 Mhz hochgeschruabt ist, dank der CPU. Ich habe einen Mac Pro 5.1 (Mid 2010) und einen 4.1 (Early 2009) und da lag es nahe, den 4.1er auf 5.1er zu bringen. Das klappt auch schnell und einfach. Man muss das Update nicht machen, aber kann es, speziell wenn man seinen Mac Pro mal richtig aufrüsten will.

Das ermöglicht einem eine größere Auswahl an Prozessoren. Neben weiteren nahalems, bekommt man auch die neueren Westmers von Intel auf den 4.1er drauf. Ich habe mir einen Xeon W5650 gebruacht für 160 EUR ersteigert, um einen Test u starten. Die werden meist im Doppelpack verbaut, wollte aber nur einen der 6-Kerner verbauen, da mein Board nur für Single-CPUs ausgelegt ist.

×

Notiz

Ein Upgrade ist immer OK, aber beim Downgrade am besten aufpassen, da die Early 2009 4.1er Firmware keiner 6-Kern-Prozessoren akzeptiert, und man nicht mehr booten kann, bis man einen 4-Kerner drin hat. Damit fährt man generell mit dem 2010er immer besser. Das Tool wird einem das noch einmal sagen...

Down-Grade-Upgrade

Das Flashen an sich ist denkbar einfach:

  1. Das Upgrade Tool herunterladen
  2. Tool starten und Upgrade bestätigen mit „Upgrade to 2010 Firmware“.
  3. RAMdisk wird vorbereitet, notwendige Daten heruntergeladen.
  4. Sobald fertig, schaltet man den Mac aus
  5. Dann auf den Power-Knopf drücken und nicht los lassen, bis die weiße LED blinkt
  6. Der Mac Pro macht einen langen Pipeton, nicht wundern
  7. Danach wird Firmware geflasht
  8. Nach dem Neustart logged man sich ein und sieht, dass man einen Mac Pro 5.1 hat
  9. Erledigt

MacPro.5.1-Detail

Danach kann man an den CPU und RAM Wechsel gehen. RAM ist aber keine Pflicht….

Prozessoren kompatibel vor dem Upgrade:

  • Intel® Xeon® E5520 Nahalem 4-Core (8M Cache, 2.26 GHz, 5.86 GT/s) UVP: $391.00
  • Intel® Xeon® X5550 Nahalem 4-Core (8M Cache, 2.66 GHz, 6.40 GT/s) UVP $999.00
  • Intel® Xeon® X5570 Nahalem 4-Core (8M Cache, 2.93 GHz, 6.40 GT/s) UVP: $1443.00
  • Intel® Xeon® W3520 Bloomfield 4-Core (8M Cache, 2.66 GHz, 4.80 GT/s) UVP: $305.00
  • Intel® Xeon®  W3540 Bloomfield 4-Core (8M Cache, 2.93 GHz, 4.80 GT/s) UVP: $594.00
  • Intel® Xeon®  W3580 Bloomfield 4-Core (8M Cache, 3.33 GHz, 6.40 GT/s) UVP: $1059.00

Nach dem Upgrade kommen folgende dazu:

  • Intel® Xeon®  E5620 Westmere-EP 6-Core (12M Cache, 2.40 GHz, 5.86 GT/s) UVP : $391.00
  • Intel® Xeon®  E5645 Westmere-EP 6-Core (12M Cache, 2.40 GHz, 5.86 GT/s) UVP: $554.00
  • Intel® Xeon®  W3530 Bloomfield 4-Core (8M Cache, 2.80 GHz, 4.80 GT/s ) UVP $305.00
  • Intel® Xeon®  W3565 Bloomfeld 4-Core (8M Cache, 3.20 GHz, 4.80 GT/s) UVP $305.00
  • Intel® Xeon®  W3680 Westmere-EP 6-Core  (12M Cache, 3.33 GHz, 6.40 GT/s) UVP: $594.00
  • Intel® Xeon®  X5650 Westmere-EP 6-Core (12M Cache, 2.66 GHz, 6.40 GT/s) UVP $999.00
  • Intel® Xeon®  X5670 Westmere-EP 6-Core  (12M Cache, 2.93 GHz, 6.40 GT/s ) UVP: $1443.00
  • Intel® Xeon®  X5675 Westmere-EP 6-Core (12M Cache, 3.06 GHz, 6.40 GT/s) UVP: $1443.00

Dank geht an netkas Crew, speziell an MacEFiRom.

Wie geht es weiter? Ich habe mir einen W5650 bestellt und werde diesen testweise verbauen und ein Upgrade später einen Artikel hierzu veröffentlichen.

Error: 5570 – Was nun?

Es gibt wohl eine Lösung, die das Problem behebt. Der Fehler tritt wohl vermehrt auf.

  • Um diesen zu umgehen, am besten das Mac Pro Firmware-Update 1.5 mit Dateinamen „MacProEFIUpdate.dmg“ direkt bei Apple herunterladen.
  • Die Datei auf den Desktop schieben und Doppelklicken, damit sie gemountet wird
  • Dann das oben benannte Firmware Upgrade Tool starten, woraufhin es diese Firmware findet und das Upgrade durchläuft

Danke an Jürgen für den Tipp!

This entry was posted onDonnerstag, April 10th, 2014 at 17:08 and is filed under . You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

About the author: Andromeda X

Als Quereinsteiger befasse ich mich nach langer Zeit auch mit der Mac-Welt, die viel mehr als eine erfreuliche Alternative ist. Als Autor möchte ich viele Informationen und hilfreiche Guides, News und Testberichte bereitstellen.

93 Comments

  1. Danke schön für die tolle Anleitung ! Hat mich auf jeden Fall weitergebracht.

  2. Alex Schielke

    hallo leider kommt bei mir das ein erro 5570 besteht. Was ist das? Danke

  3. Moin Alex. Welche nicht-standardgemäße Hardware hast du drin? Welches OS hast du?

  4. Hans-Günter Thiel

    Hallo Leute,

    ich habe hier einen Mac Pro 4.1 mit 2x 2,26mhz Quattro Prozessoren mit 8gb Speicher.
    Wenn ich hier nach Anleitung vorgehe, bekomme ich folgende Meldung:
    The program has encountered an error: 5570

    Hat jemand eine Lösung?
    Besten Dank im Voraus und Grüsse von der Mosel
    HaGueTH

    • Ich habe schon so einen Kommentar gehabt. Hast du Mehr Details zu deinem System? Bei mir klappte das auf Anhieb. Ich habe aber unter Mavericks geflasht. Fürchte ja, dass Yosemite daran Schuld sein könnte! Hast du Info zu deinem OS?

  5. Jürgen

    Hallo Andromeda,

    ich hab hier mit meinem Mac Pro 4.1 2 x 2.26GHz mit Mavericks 10.9.4 dasselbe Problem. Beim Starten des Tools erstmal alles normal, nach Passworteingabe wird der RAM-Disk erstellt, die Files werden runtergeladen und nach dem Download sollten Files extrahiert und gepatcht werden. Und genau in diesem Moment kommt der Error 5570. In meiner Kiste ist alles Original, nichts in den PCIe-Steckplätzen, kein USB-Stick angeschlossen und eine GeForce GT120 Grafikkarte ist verbaut. Hast du eine Idee?

    Gruss
    Jürgen

  6. Jürgen

    Hier in Post 2 ist vielleicht die Lösung, werds nachher gleich selber ausprobieren.
    http://forum.netkas.org/index.php/topic,8729.0.html

    Gruss
    Jürgen

  7. Jürgen

    Obengenannter Link bringt die Lösung, grade getestet und es hat funktioniert. 🙂

    Ich hab jetzt einen Mac Pro 5.1 🙂

    • Hey Jürgen,

      habe vorher auch mal gesucht, aber nicht die Ursache gefunden. Danke für den Tipp! Ich habe meinen Artikel aktualisiert. Gratuliere zu deinem 5.1er Mac pro 🙂

  8. Jürgen

    Büdde gerne. Wäre ja schade, wenn`s an sowas scheitert und glücklicherweise hat ja jemand einen Workaround um dieses Problem gefunden. 😉

    Gruss
    Jürgen

  9. Hans-Günter Thiel

    Hallo Leute,

    ich danke euch für die schnelle Hilfe.
    Werde mal den Link von Jürgen durchgehen.
    Hatte diesen Link bei meiner suche auch schon gefunden, da mein Englisch aber nicht so gut ist, bin schon etwas älter, diesen erst mal übergangen.

    Meine Ausrüstung besteht aktuell wieder aus einem Mac Pro 4.1 8 Kern 2.26.
    Habe noch einen Apple IIc, SE, 6100/60, 6100/66 und einen G4 Digital Audio.

    Grüsse von der Mosel
    HaGueTH

  10. Hans-Günter Thiel

    Hallo Leute,
    habe die Datei runtergelassen und bekomme folgende Meldung:
    Diese Software wird von Ihrem System nicht unterstützt.

    Hier mal mein System:
    Hardware-Übersicht:

    Modellname: Mac Pro
    Modell-Identifizierung: MacPro4,1
    Prozessortyp: Quad-Core Intel Xeon
    Prozessorgeschwindigkeit: 2,26 GHz
    Anzahl der Prozessoren: 2
    Gesamtanzahl der Kerne: 8
    L2-Cache (pro Kern): 256 KB
    L3-Cache (pro Prozessor): 8 MB
    Speicher: 8 GB
    Geschwindigkeit für Prozessorverbindungstyp: 5.86 GT/s
    Boot-ROM-Version: MP41.0081.B07
    SMC-Version (System): 1.39f5
    SMC-Version (Prozessormodul): 1.39f5
    Seriennummer (System):
    Seriennummer (Prozessormodul):
    Hardware-UUID: 58DA74B6-93D3-5C36-87E7-74CC812FE10E

    Vielleicht hat jemand eine Lösung.

    HaGueTH

  11. Jürgen

    Hans Günther,
    Du sollst ja auch nicht diese Firmware-Datei von Apple installieren, sondern diese ZIP-Datei auf die Schreibtischoberfläche extrahieren. Wenn das gemacht ist das Upgrade Tool starten, es wird dann die Original Apple-Firmware-Datei auf dem Schreibtisch erkennen und sie zum Upgrade benutzen. Ohne Upgrade Tool gehts nicht, da mit dem Upgrade Tool Apples Sperre umgangen werden muss.

    Viel Erfolg wünsch ich Dir. 😉

  12. Jürgen

    Ups… noch eine kleine Korrektur:
    Nach dem Extrahieren des ZIP-Files hast Du ein DMG-File mit dem Namen „MacProEFIUpdate.dmg“.
    Da klickst Du einmal drauf, damit es gemountet wird, das heisst, es wird dann wie eine Festplatte angezeigt im Finder.
    Und dann startest Du das Upgrade Tool.
    Wenn Du die „Firmware-Festplatte“ anklickst und das Pkg-File doppelklickst kommt die von Dir beschriebene Fehlermeldung.

  13. So wie es Jürgen beschrieben hat, sollte es eigentlich gehen. Hoffe es klappt nun. War leider unterwegs, konnte nicht eher antworten.
    Günther, klappt es nun?

  14. Hans-Günter Thiel

    Danke Leute,
    es hat endlich funktioniert.
    Nach mehreren Versuchen, mit gedrückter Shift Taste, mit der Alt Taste, ich hab mir extra eine Snow Leopard DVD besorgt, da beim gebrauchten Mac keine dabei war, hat es nun endlich funktioniert.
    Er zeigt mir nun 5.1 an.
    Nochmals viel vielen Dank an Euch.
    Ausschlag gebend war wohl das Starten mit gedrückter Shift Taste.
    Da hier die Startplatte untersucht und berichtigt wird, laut Google.

    Mir viel bei dieser Aktion auf, das die 10.6. DVD mit einem blauen Bildschirm startet und nicht durch läuft.
    Kann es daran liegen, das ich Tastatur und Maus, vom Windows System, über einen Switch angeschlossen habe?
    Der Switch schaltet mir Tastatur, Maus und 2 Bildschirme auf bis zu 4 Rechnern um. Zur Zeit 2 Mac´s und 1 Windows Rechner. Wirklich eine tolle Sache.

    Nochmals vielen Dank von der Mosel
    HaGueTH

  15. Danke für das Feedback. Schön dass es bei allen soweit geklappt hat. Damit wird aus diesem Beitrag auch ein wirklich vollständiger Artikel 🙂

  16. Bernhard

    Hallo,
    danke für den Beitrag. Hat wunderbar geklappt!
    -Bernhard

  17. Michael

    Hallo,

    ich habe seit längerem das Firmwareupgrade gemacht. Unter Mavericks läuft es tadellos. Als ich allerdings Yosemite installieren wollte, ging das ganze schief (Speicherfehler, Meldung falsche Firmware usw.). Kann mir jemand sagen, wie ich hier Abhilfe schaffe und mein System mit Yosemite zum laufen bekomme?

    Vielen Dank

  18. Hi Michael,

    ich habe auf meiner Kiste erst vor kurzem Yosemite neu installiert, da ging es gut. Muss dazu sagen, dass da aber auch Yosemite auch schon dabei drauf war. Ich hatte aber vor dem Flashen auf 5.1 auch noch Mavericks drauf und das Update ging bei mir ohne Probleme. Auch bei einem Kollegen klappte das. Hast du mal probiert den SMC zu resetten?
    https://www.google.de/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CCEQFjAA&url=https%3A%2F%2Fsupport.apple.com%2Fde-de%2FHT201295&ei=rndlVanUB4mqUbzigPAN&usg=AFQjCNFKXnqa2wXyd6pRc3IdNY4DqgFZvw&sig2=furoD8JyKrhDHJ5h5SB2Cw&bvm=bv.93990622,d.d24

    • Michael

      Hi Andromeda,

      danke für die schnelle Antwort (finde ich richtig toll) und den Tipp. Ich werde es am Sonntag mal ausprobieren, da ich Morgen für ein paar Tage im Ausland bin. Ich gebe dann Bescheid, welchen Erfolg ich dann gehabt habe. Bis dahin wünsche ich dir eine schöne Woche.

      Gruß
      Michael

  19. Hey Michael,

    das kann halt durchaus an den Kleinigkeiten liegen. SMC oder PRAM liegen: https://www.google.de/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CCEQFjAA&url=https%3A%2F%2Fsupport.apple.com%2Fde-de%2FHT204063&ei=1hdnVc2mH4n0UKvcgNgO&usg=AFQjCNGB_IS-gQADtjSLqGpd3TnEp3ExXg&sig2=Pd7rrFw88ZnFzmLJVTlZDw&bvm=bv.93990622,d.d24

    Eins von beiden könnte es sein. Bitte nenne die genaue Fehlermeldung/-nummer, falls die vorliegt

    • Michael

      Hallo Andromeda,

      jetzt hat es funktioniert (nachdem ich den Rechner komplett ausgeschaltet habe (Netzstecker ziehen).
      Yosemite ist drauf. Nochmals vielen Dank für die Tipps und Hilfe.

      Gruß und noch eine schöne Woche

      Michael

      • Hi Michael,
        super, dass es nun geklappt hat. Viel Spaß mit deinem 5.1er Mac Pro 🙂
        Andy

  20. Johnny Walker

    Hey Leute!
    kann man nach diesem Upgrade die alte GForce GT 120 ohne Probleme verwenden und werden dann schnellere RAM Speicher unterstützt 1066 auf 1333 MHz?

  21. Hey Johnny,

    Die GT 120 sollte eigentlich gehen. Wäre doch komisch, wenn die Treiber nicht mehr greifen würden. Was den RAM angeht, habe ich 2 Fälle. Bei mir taktete der RAM nicht auf 1.333 Mhz hoch, beim Kollegen schon. Es sollte in beiden Fällen gehen, war aber nicht so. Mir ist noch immer nicht klar woran es lag. Hab mit mehreren Modulen getestet.

  22. Jürgen

    Die GT120 geht auf jeden Fall, bei mir läuft sie tadellos.
    Ob die RAM`s auf 1333MHz takten hängt zum einen von den RAM`s ab und zum andern von der CPU. Nicht jede CPU unterstützt 1333MHz Taktfrequenz.
    Gefunden auf macrumors.com:
    If you replace them with non-genuine CPU’s X5570’s (with headspreader) or X5670/X5675’s then RAM will be working as 1333 MHz.

    Hoffe, konnte helfen. 😉

    Gruss Jürgen

  23. Günter Schwiebert

    Ich habe heute unter Yosemite 10.10.5 meinen MacPro 4.1 wie oben beschrieben auf 5.1 geflasht. Prozessor: Singe CPU 2,66 GHz; W3520
    Die Hardware ist per heute unverändert geblieben; ich plane aber einen W3690 einzubauen.
    Das Flashen klappte problemlos (Firmware Tool + Apple Update-Programm). Das einzige Manko, das ich bisher feststellen konnte ist, dass eine Startoption nicht mehr über die gedrückte Optionstaste bei Neustart bestimmt werden kann. In diesem Fall erscheint ein weißer Bildschirm, auf dem sich lediglich der Cursor befindet, aber nichts ausgewählt werden kann. Alle anderen Funktionen: cmd+R, cmd+P+R, cmd+S, cmd+Shift funktionieren einwandfrei. Gibt es auch hierfür eine Lösung?

    • Hey, das ist mir neu. Hast du geschaut, ob nicht irgend eine DVD oder Stick dran sind und den Bootloader hindern?

      • Günter Schwiebert

        Nein, da war weder eine DVD noch ein Stick angeschlossen. Ich kann das Upgrade (Mac Pro 2009-2010 Firmware Tool) auch nicht wiederholen, da es ja (ansonsten erfolgreich) ausgeführt wurde. Dies gilt natürlich erst recht für das MacProEFIUpdate, das ja nur im Zusammenhang mit dem Firmware-Tool ausgeführt ist.
        Ich komme an diesem Punkt nicht weiter. Habt ihr eine Idee?

        • Günter Schwiebert

          Ich habe jetzt den Grund dafür gefunden, dass ich beim Start mit gedrückter Option-Taste keine Auswahl der Startvolumes erhalte; es liegt an der installierten Sonnet Tempo SSD. Auf der Support Seite von Sonnet heißt es:
          „Tempo SSD and Tempo SSD Pro bootable drives show upon an option-boot in the Mac Pro 3,1 and 4,1, but do not show up in the Mac Pro 5,1. The recommended workaround in a Mac Pro 5,1 is to boot from another drive, and then select the Tempo SSD volume in the Startup Disk System Preferences and restart.“
          http://www.sonnettech.com/support/kb/kb.php?cat=457&expand=_a2_b760_b758_a13_a1&action=b686#b686
          Dann kann ich das halt nicht ändern.

          • Es sind oft so kleine Sachen, die man ausschließt, die den ganzen Unfug verursachen. Die nächsten, die das Problem haben, werden aber dank dir schnell fündig. Danke

  24. CV

    Hallo zusammen –

    habe alles genau so ausgeführt wie beschrieben (1. MacProEFIUpdate.dmg von Apple-Website
    runter geladen, 2. – Achtung: das file doppelt geklickt, damit der Ordner sich öffnet, 3. die
    dmg-Datei dort EINMAL geklickt, wie von Jürgen beschrieben, DANN erst zeigt sie sich als unter
    ”Geräte”, also als mountbares Medium und dann, 4., das Firmware-Tool gestartet.) Das ging alles
    schnell und elegant. Auch der Start nach dem Ausschalten: das Licht flackert, habe dann den
    Button losgelassen, dann ertönte der Ton.

    Aber der Sytembericht sagt mir, dass ich immer noch einen MacPro4.1 habe. Hat sich auch
    nicht nach erneutem Starten mit gedrückter Shift-Taste geändert.

    Habe das ganze ProCedere auch noch mal wiederholt. Ohne Erfolg.

    Hab’s auch mal mit gedrückter Shifttaste versucht – es bleibt bei 4.1.
    Zumindest im Systembericht. (Vielleicht habe ich ja schon einen 5.1 – einen
    versteckten.)

    Was ist zu tun?

    • Hey Carsten, welches MacOS X hast du denn genau drauf? Bisher hat es ja bei allen geklappt. Nur Mit El Capitan hat es glaube ich keiner gemacht. Nicht dass es da irgendwo einen Bug gibt.

  25. CV

    Hallo zusammen –

    ich habe nun die Lösung für das Upgrade vom MacPro4.1 auf 5.1 – unter El Capitan!

    Unter dieser letzten OS-Version hat Apple das SIP-System eingebaut, das System
    Integrity Protection, das es erschweren soll, die Rechner mit Malware zu korrumpieren.
    Dieses SIP blockiert auch den Upgrade-Prozess, wie er hier beschrieben wird.

    Man kann das SIP aber ausschalten. Und das geht so:
    1.) Der MacPro4.1 ist ausgeschaltet.
    2.) Ihr startet den Rechner und haltet dabei die cmd- zusammen mit der R-Taste gedrückt,
    solange bis das Apple-Symbol und der Ladebalken erscheinen.
    3.) Nach einer Weile taucht in der Menuleiste das OS-Dienstprogramm auf. Unter dem
    Menüpunkt ”Dienstprogramm” wählt ihr das Terminal aus.
    4.) Dort erscheint dann: -bash-3.2#, dahinter gebt ihr dann die Worte: csrutil disable ein
    und bestätigt (via enter-Taste).
    5.) Daraufhin folgt ein Text, der bestätigt, dass SIP disabled wurde.
    6.) Anschließend startet ihr den Rechner neu.

    Wenn ihr jetzt das hier im Blog beschriebene ProCedere durchlauft, sollte es mit eurem
    Upgrade klappen. Bitte fertigt für den Fall der Fälle aber ein Backup eurer Daten und
    eures Systems an. Habe ich auch gemacht – obwohl alles butterweich ablief.

    Um das SIP wieder einzuschalten, geht ihr genauso vor, wie ich es gerade in den Punkten
    1 – 6 beschrieben habe, setzt dann aber die Worte: csrutil enable ein.

    Viel Erfolg & beste Grüße,

    CV

    • ko

      Danke! Das brachte bei mir die Lösung. Hiermit funktioniert der upgrade unter El Capitan.

    • Chris

      Der Schritt zur Deaktivierung der SIP (System Integrity Protection) unter ElCapitan sollte im Artikel erwähnt werden.

      Denn daran hatte ich auch nicht mehr gedacht.
      Jetzt läuft er wieder als 5.1er.

      Mich wundert es, warum und wie er nach SSD-, CPU-Board-, RAM-tausch und co. überhaupt zurück zu einem 4.1er kam.

  26. Paul

    Hallo,

    ich habe in meinen Mac Pro 5,1 eine W3670 CPU in meinem Mac Pro eingebaut, leider fährt der Mac Pro nicht mehr hoch. Irgendwann friet der Mac Pro beim (hochfahren Mac OS X 10.6) rotierenden Kreis ein und weiter passiert nichts.

    Allerdings fährt der Mac Pro einwandfrei mit Windows 7 im Mac Pro hoch! Auch Burn In Programme und Apple Hardware Test melden keine Fehler.

    Kann mir jemand weiterhelfen?

    Gruß
    Paul

    • Hey Paul, der ist nicht auf meiner Liste. Mac OS X schaut ja, was du hast, und erkennt die als inkompatibel.

  27. Lake

    Hi Leute, danke erstmal an die Autoren!

    Frage: Sind „nur“ die oben genannten CPUS nach dem Firmeware Upgrade kombatibel? Also kann man z.b zwei X5690 rein knalle? oder 5577? usw.

    Wo finde ich, sofern es mehr als die oberen gibt, eine Liste alles CPUS?

    • Ich habe nur die erprobt, die auch in Mac Pro Modellen verbaut werden. Apple ist dafür bekannt, nur exakt das zu unterstützen, was die auch nutzen. Alles andere endet oft in Frust. Ich würde aus dem Grund nur zu erprobten Sachen greifen, die Apple auch so ausgeliefert hat.

  28. Lake

    Der x 5675 ist nach dem Upgrade der beste alles Verfügbaren CPUs?

    • Ja, der X5675 Westmere-EP sollte wohl das beste Modell sein, das du verbauen kannst. Andere sind mir nicht bekannt.

  29. Paul

    Hallo,

    ok! In einigen anderen Foren wird auch der W3670 verbaut, allerdings ohne irgendeine Softwareanpassung.

    Die CPU wird eingebaut und der Rechner fährt unter Mac OS X hoch.

    Gruß
    Paul

  30. Paul

    Am Rechner?

    Nein wurde nichts geändert.

  31. Franzl

    Ich habe zwei X5680 rumliegen, die Liste der unterstützen CPUs geht nur bis zum X5675. Ist das immer noch aktuell?
    Gruß Franz

    • Mir liegen keine Informationen vor, dass die unterstützt werden, sorry

    • Lake

      Hat bisher jemand den x5680 ausprobiert?

  32. Lake

    Hi Leute, Ich habe einen MAC PRO 4.1, und wollte auch das Upgrade machen.
    Klappt auch, 5570 Fehler Umgehen mit dem APPLE Direkt EFI usw. dann ausschalten – einschalten gedrückt halten:
    die LED blinkt, der lange Ton kommt und ich lasse sofort los beim Neustart…

    Habe es 3 x gemacht, bleibt bei Mac Pro 4.1.. einer ne Idee?

    • Hast du irgendwelche abweichende Hardware drin oder so? Ich habe noch einen Nachtrag von einem der Leser gekriegt, der auch so ein Problem hatte! Baue ich gleich ein

  33. Clint

    Gleiches Problem, sogar auf zwei Rechnern. Ist und bleibt ein 4,1…
    Einer hat eine RAID-Karte drin und SSD-Laufwerke, der andere weder das Eine noch das Andere. Trotzdem beide stur 🙁

    • Lake

      Problem Firmeware upgrade wird nicht übernommen
      Lösung: Temporär „ROOT Rechte“ erlangen: disable SIP
      1. reboot
      2. as soon as you hear the „Mac sound“ on the grey screen, press Cmd+R to enter Recovery mode
      3. Open Utilities->Terminal
      4. Run the command csrutil disable
      5. Reboot, you’ll land in the normal OS with SIP disabled
      6. Upgrade durchlaufen lassen mit Neustart etc.
      7. Reboot again
      8. as soon as you hear the „Mac sound“ on the grey screen, press Cmd+R to enter Recovery mode
      9. Enable SIP with csrutil enable
      10. Reboot again
      11. done

      • Jo

        Merci, hat geklappt. 🙂

        In „Über diesen Mac“ in der Übersicht steht übrigens immer noch 2009er, allerdings im Systembericht steht jetzt MacPro5,1.

        • Jo

          Sierra installing….. 😀

          • Ausgezeichnet! Dann viel Spaß 🙂
            Bei meinem 5.1er rennt Sierra ganz „ok“. Heute hat sich die Kiste aber aufgehängt im Standby -_-

  34. Lake

    Problem Firmeware upgrade wird nicht übernommen
    Lösung: Temporär „ROOT Rechte“ erlangen: disable SIP

    1. reboot
    2. as soon as you hear the „Mac sound“ on the grey screen, press Cmd+R to enter Recovery mode
    3. Open Utilities->Terminal
    4. Run the command csrutil disable
    5. Reboot, you’ll land in the normal OS with SIP disabled
    6. Upgrade durchlaufen lassen mit Neustart etc.
    7. Reboot again
    8. as soon as you hear the „Mac sound“ on the grey screen, press Cmd+R to enter Recovery mode
    9. Enable SIP with csrutil enable
    10. Reboot again
    11. done

  35. Sandro

    Hilfe,
    Wenn ich das „MacProEFIUpdate.pkg“ Starte kommt gleich “ Warnung: Diese Software wird von ihrem System nicht unterstützt.“
    SIP Disable funktioniert auch nicht. „command not found“
    Extra 10.6/7/8/11 installiert funktioniert nicht…
    Ich habe eine Apple Raid karte verbaut, sollte ich diese mal vorübergehend ausbauen?

    Besten Dank jetzt schon für eure Hilfe

  36. Sandro

    Jupi!!!
    Alles hat geklappt! Man sollte vielleicht in diesem Kontext noch erwähnen, dass es für die Datei auch noch Programm dazu separat braucht!
    „Mac Pro 2009-2010 Firmware Tool.zip“ Hier der Link dazu! viel spass!
    http://www.macuser.de/threads/macpro-firmware-hack-4-1-2009-upgrade-auf-5-1-2010-firmware.619437/

    Die zwei schmuckstücke sind jetzt unterwegs! 😉
    Intel® Xeon® X5675 Westmere-EP 6-Core (12M Cache, 3.06 GHz, 6.40 GT/s)

    • Nice, freue mich auch immer mit, wenn alles klappt. Dual-CPU-Boards sind auch zu verlockend!

  37. Jürgen

    Also die schnellste CPU, die ich gefunden habe, die man in den Mac Pro 5.1 verbauen kann ist der X5690…. mal so als kleiner Nachtrag… dann hat man eine 3.46 6-Core CPU, die passen in die Sockel der 8-Core Maschinen und unterstützen auch 1333MHz-RAM-Riegel… bei den 4-Core Macs weiss ichs nicht sicher, müsste aber auch gehen, sollten ja dieselben sockel sein, nur einmal (4 Core) in einmaliger Ausführung und einmal (8-Core) in zweifacher ausführung. 😉
    Da ist man dann mit dem Geekbench mal bei so ca. 32`000 Leistungspunkten… mehr als der schnellste serienmässige Mac Pro Late 2013. 😉

  38. Mantra

    Hallo MacPro Fans.

    Nach allen euren wirklich supertollen Anleitungen schaffe ich es nicht den Mac zu flashen.

    Status:
    MacPro 4.1 Early 2009
    2.66 Quad Core
    24GB ram
    Nvidia GT 120
    OS 10.11.3
    2x Cinema 23 Zoll
    2x SSD (System) und 2x HD

    Mein Vorgehen:
    Habe das SIP deaktiviert.
    Anschliessend das 1.5 EFI Upgrade gemountet und das Mac pro Firmware Tool laufen gelassen.
    Hat alles funktioniert, und wie beschrieben habe ich den Mac ausgeschaltet, und mit blinken und piepsen neu gestartet. Zwischendurch habe ich das Prozedere wiederholt und davor dem P-Ram gelöscht. Leider hat auch das nicht viel gebracht.

    Habt ihr irgendwelche Ideen, was ich noch versuchen könnte?

    Danke im Voraus für eure Inputs!

    Beste Regards!

    Mantra

  39. Winni

    Hallo Zusammen

    Spiele mit dem Gedanken meinen 4.1er (2.26GHz) auf den 5.1er zu Flachen.
    Background: Ich hab hier noch zwei Xeon W5647 CPU’s rum liegen.
    Weiss jemand ob ich diese auch laufen?

    • In der Liste stehen sie nicht und erprobt habe ich das nicht. Auf die Schnelle konnte ich dazu auch nichts finden. Also würde ich „inkompatibel“ sagen.

  40. Computerraven

    Hallo,
    Habe versucht unter 10.11 zu flashen geht aber nicht,
    mit 10.7 gehts.

  41. Murti74

    Was ich nicht ganz verstehe was sich dadurch für mich ändern würde? Ok ich kann wenn ich mal einen Prozessor Update machen würde auf mehrere zugreifen. Aber ich habe danach z.b meinen Speicher von 1066 er Modulen auf 1333 Modulen ausgewechselt und diese werden weiterhin als 1066 erkannt. Hat also keinen Mehrwert für mich gehabt. Oder habe ich etwas falsch gemacht?

    Liebe Grüsse
    M

    • Normalerweise würdest du 1333er RAM haben. Außerdem sieht dein Mac neuer aus, weil sich technisch nicht viel getan hat 😉 Prozessorwahl ist ja auch nunmal wichtig…

  42. Vielen Dank für die Tipps für das 5.1 Upgrade.
    Hat auf meinem Rechner unter 10.11.6 wunderbar geklappt, sofern man zuvor das Terminal bemüht hat.

    Nur wird bei mir der neue 1333MHz Ran nicht erkannt, er läuft weiter mit 1066 MHz.
    Oder ist das abhängig von einem Prozessorupgrade. Ich habe noch die alten 2,66 MHz Prozessoren in Betrieb.
    Tausend Dank für eine Antwort!

    System: 10.11.6
    2×2,66 MHz Prozessor
    32GB Ram
    Nvidia Quadro 4000
    Apple Raid Karte
    DeckLink SDI 4k

  43. Fritzwalter

    Hallo
    habe heute folgendes gemacht.
    Ein Mac Pro 4.1 2009 Quad mit 2,93 MHz das 5.1 Firmupdate aufgespielt.
    Dann 1333 Ram eingebaut und anschließend System gestartet.(10.12).
    System erkennt Speicher weiterhin nur mit 1066Mhz.

    Da ich noch eine X5570 CPU hatte habe ich diese ausprobiert und siehe da Speicher wird mit 1333 MHz getaktet.
    Habe mir dann die Alte CPU etwas näher angeschaut und musste feststellen das diese als W3540 bezeichnet wird.
    Auf der Seite von Intel mir die Technischen Daten angeschaut .Der Speichertakt wird hier mit max 1066Mhz
    angegeben.
    Dies wäre natürlich auch eine Erklärung warum es bei manchen geht und bei anderen nicht.
    Also X5570 2,93mhz Speichertakt bis 1333 MHz

    W3540 2,93mhz Speichertakt bis 1066 MHz

    beste grüsse
    fritzwalter

    • Sigi

      Na ja nicht ganz Richtig, bei mir sind verbaut 2x X5675 und der Taktet Lt.Intel Ram auch mit 1333 Mhz
      Und bei mir obwohl 1333Mhz Installiert sind,aber nur 1066Mhz meldet, also irgendwo muß hier ein hacken sein von wegen Netkas Efi Rom, man muß schon anerkennen das Sie möglich gemacht haben den 4.1 zum 5.1, aber vielleicht noch ein Kleine Schliff Brauch das Rom Efi Upgrade!

  44. Joachim Gast

    jgast@t-online.de
    Habe Snow leopard auf einer extra Festplatte installiert ,dann ging das flachen wie es sollte.

  45. Klaus

    Hallo,

    hat alles großartig funktioniert. inkl. Fehlerbehebung 5570.

    Ganz klasse. Vielen Dank!

    Klaus

    7.10.2016

  46. Friedrich B. Everling

    Vielen Dank für den Tip, ich habe meinen MacPro 4,1 (QuadCore) auf 5,1 angehoben und konnte anschließend MacOS Sierra installieren. Folgende Stolpersteine waren zu bewältigen:
    1. Beim Booten von einer Samsung SSD mit El Capitan klappte es nicht, dafür aber von einer internen HD mit mit 10.8.5.
    2. Dann fand sich die SSD in der Systemeinstellung „Startvolumes“ nicht. Kein Problem bei Neustart mit gedrückter Wahltaste.
    Ansonsten scheint bislang alles gut geklappt zu haben. Nochmals Dank.
    Friedrich

  47. Bernd Limbach

    Danke für die Anleitung und die Ergänzung zu El Capitan. So hat das flashen unter 10.11.6 erfolgreich funktioniert.

  48. Thomas

    Hi,
    als erstes einmal danke für die tolle Anleitung. Hat alles prima geklappt.
    Dann habe ich eine Frage bzw. Einen Kommentar an Fruederich.
    Ich habe das gleiche Problem mit dem Arbeitsspeicher, aber trotzdem ich zwei Intel Xeon X5680 verbaut habe wird bei meinem Arbeitsspeicher immer noch 1066MHz angezeigt. Hast du oder jemand Anderer noch eine Idee?
    Viele Grüße und nochmals tausend Dank
    Thomas

  49. Rainer

    Hi, ich habe den Fehler 5530. Upgrrading von 4.1 >5.1 – Habe zwei identische MacPros, bei einem hat es wunderbar geklappt, beim andere nicht…. 🙁

  50. Christoph

    Ich habe einen Mac Pro 5,1 mit 2,8GHz Quad-Core CPU. Welche CPU ist die beste, die ich nun stattdessen einbauen könnte?

  51. Detlef Baars

    Erstmal vielen Dank für die gut dokumentierte Anleitung. Mein Mac (Early 2009) hat jetzt eine Firmware 5.1. Zunächst habe ich einen X5690 Six-Core mit 3.46 GHz eingebaut. Alles gut. Probleme habe ich mit dem Speicher. Verbaut wurden 4x 4 GB 1033 / 1333 MHz. Getacktet werden sie aber nur mit 1066 MHz, obwohl der Prozessor laut Intel auch 1333 MHz Speicher unterstützt. Liegt das an dem verwendeten RAM oder gibt es noch andere Ursachen? Wer kann mir helfen?

    Grüße aus Wolsdorf

    Detlef Baars

    • Moin Detlef. Ich habe das Problem auch schon gehabt. Ich glaube es liegt an dem RAM. Bin mir aber nicht sicher, weil ich keinen weiteren RAM herumliegen hatte, um das zu testen

  52. joethebest

    „Hi, ich habe den Fehler 5530. Upgrrading von 4.1 >5.1 – Habe zwei identische MacPros, bei einem hat es wunderbar geklappt, beim andere nicht…. “

    Hatte vorher das gleiche Problem. Fehler behoben.
    Erst die 2009er firmware auf 1.0081.B07 -EFI 1.4 aktualisieren. Dann ging es nach Anleitung!

    /Danke für die tolle Hilfe hier!

  53. joethebest

    Damit die Speicher mit 1333 MHz laufen einfach den Parameter-RAM zurücksetzten!
    (Bei Systemstart alt-cmd-p-r).
    Danach werden 1333 anstatt 1066 angezeigt.

    • Danke für den Ratschlag. Bei mir hatte es damals nicht funktioniert. Habe nur noch den echten 5.1er. Wäre cool wenn es einer der Nutzer testen könnte 😀

    • Sigi

      @joethebest vielen Dank, meine 64 Gb RAM sind jetzt alle 1333Mhz

  54. Björn

    Hallo, bei mir will und will es nicht klappen, ich mache das erste mal Firmware gemacht = Fehlercode 5570, dann das Tool runtergeladen, lässt sich nicht öffnen, Datei defekt, ok, nochmals Firmware gemacht, nun ging es, aber es wird mir immer noch nach dem Neustart 4.1 angezeigt, auch die 1066 statt der 1333 MHz bleiben hartnäckig bestehen…
    Ich habe nun El Capitan auf dem Rechner und irgendwie will er nicht, liegt es am Betriebssystem?

    Wäre für Hilfe echt dankbar!

    lg Björn

  55. Christoph

    Wenn ich einen gebrauchten Mac Pro kaufe, wie erkenne ich dann, ob es ein echter Mac Pro 2010 ist oder ein geflashter Mac Pro 2009?

  56. tonne

    Hallo! Tolle Hilfestellung hier. FW-Upgrade auf 5,1 hat super geklappt. Vielen Dank. Aber warum steht in den Systemeinstellungen (Über diesen Mac) immer noch Early 2009 anstatt Mid 2010? Siehe: http://www.mac-elite.de/wp-content/uploads/MacPro.5.1-Detail.pngWo kann das geändert werden? Besten Dank, tonne

  57. Hi,

    hat wunderbar geklappt. Danke für die Anleitung!

  58. Hallo liebe Macianer
    habe versucht mit dem Netkas tool meinen Standard 2,66 mac pro 4,1 quad in einen 5,1 zu konvertieren. nach error 5570
    datei von apple geladen und gemounted, tool durchlaufen lassen, funktioniert. gebooted , geblinkt, lange gebeebt.
    nur leider ist es immer noch ein 4,1.
    Reproduziert, Pram reset immer noch 4,1.
    Ich hoffe irgendwer hat eine tolle Idee.
    Need your help.
    Gruss Uli

  59. Uli Frisch

    Habs gefunden, wer lesen kann ist klar im Vorteil.
    Stand in den Kommentaren zu El Capitain.
    csrutil disable hat geholfen.
    Danke für die gute Anleitung.

    Gruss Uli Frisch

  60. Bill Hw.

    Hallo zusammen,

    ist das FW -Update persistent? Also: kann ich das System danach problemlos neuinstallieren, oder muss ich dann erneut flashen?

    Danke und Gruß,
    Bill

  61. Sillycomvalley

    Danke an Euch alle für die Anletungen, die Problemberichte und erneuten Problemlösungen.
    Nach den diversen Hürden hat es bei mir auch endlich geklappt. : )

    • Gerne. Finde es auch super, dass so viele mitgemacht haben und zum Thema mit Lösungen beigetragen haben ❤

Jetzt kommentieren

Ihre E-Mail-Adresse wird nicht veröffentlicht.

Sie können folgendes Verwenden HTML Tags und Attribute: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>